IRMaintenance service can not start

General questions and answers about infoRouter EDMS

Moderator: infoRouter Guru

Post Reply
merig
Posts: 26
Joined: Wed Dec 05, 2012 8:29 am

IRMaintenance service can not start

Post by merig » Tue Dec 25, 2012 9:13 am

Hello ,

In an attempt to improve on some performance issues on our staging environment, we attempted to move the application folder to another drive location that had more space. However there was an issue after the move in which the IRMAINTENANCE service would not start because it could not execute the service from its initial path.

If we tried to start this service in the new location drive, the service cannot start, giving an error. Does the IRMAINTENANCE need to be re-installed when and if you need to move the application folder to another destination? Please help.

User avatar
infoRouter Guru
Posts: 230
Joined: Fri Aug 07, 2009 8:46 pm

Re: IRMaintenance service can not start

Post by infoRouter Guru » Tue Dec 25, 2012 9:18 am

Hello,
You need to remove the original service and re-install the service.

Remove the infoRouter Maintenance Service
1. Using command line tool, navigate to the “c:\infoRouter\irmaintenance” directory

2. Type the following command to remove the service
irmaintenance.exe –u

Note: if the irmaintenance service was installed under another name, please use the following
command instead.
rmaintenance.exe -u <servicename>

Now install the service again from its new location

irmaintenance.exe –i

The Guru.

Post Reply

Return to “General Questions & Issues About infoRouter EDMS”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest